Thursday, March 15, 2012

Ruby Segmentation Fault

Even if there was plenty of info around, it was still a pain.

I am using Snow Leopard with RVM and Ports.

First I tried:
rvm install ruby-1.9.3 --with-openssl-dir=/opt/local \
as described in:

But even if I had the openssl 1.0 using ports and the latest iconv, it will stil give me an error.

Until I finally tried a combination of the answers at this post:

rvm remove ruby-1.9.3
export PATH=/usr/bin:/bin:/usr/sbin:/sbin:$HOME/.rvm/bin
rvm pkg install iconv
rvm install ruby-1.9.3 --with-openssl-dir=/opt/local \

Basically use openssl from ports but a local package for iconv.